Gentoo auf iMac Flat-Screen 1,25Ghz

Ich habe gestern die Installation von Gentoo auf dem iMac meiner Frau begonnen.

Gestern habe ich die 2008.0 Universal-CD gebrannt und den iMac damit gebootet, die letzten 15 Minuten habe ich damit zugebracht, den "Gentoo" Eintrag auf meiner Seite zu schreiben, also sind wir gerade bei etwa

T=30 Minuten

Der tar-ball ist ausgepackt. Ich formatiere die Platten nicht neu - vielleicht kann ich so die Daten aus Kubuntu erhalten (ja, ich habe ein Backup der wichtigen Daten). update: Hat geklappt. Alle Daten sind noch da.

Bisher hat alles reibungslos geklappt - das einzige Manko ist, dass in den docs noch lynx als Browser empfohlen wird, die CD aber stattdessen links2 hat. Muss ich noch einen Bugreport aufmachen.

T ~ 60 Minuten

Alle vorherige Kubuntu Software entfernt (rm -r /usr /lib /lib64 ..., /home ausgespart!), den stage tarball und portage snapshot installiert, changeroot ausgeführt, portage aktualisiert und die notwendige Konfiguration geschrieben - es wird ein Desktop Profil.

Jetzt kommt der Kernel.

T ~ 2 Stunden

Ich habe statt dem Befehl "genkernel -genzimage all" einfach "genkernel all" genutzt, weil der erste nicht funktioniert hat. Vielleicht ein Bug in der Anleitung?

Von der Stunde musste ich selbst nur etwa 10 Minuten was machen, den Rest hat der Rechner mit zweimal kompilieren des Kernels verbracht (einmal falsch wegen hoffentlich falschem Befehl).

T ~ 4 Stunden

Es war nicht mehr allzu viel zu tun. yaboot wollte mit "yaboot -b /dev/hda2" gestartet werden, weil meine apple bootpartition auf /dev/hda2 liegt.

Dann habe ich noch die locale eingestellt (/etc/locale.gen braucht "de_DE.UTF-8@euro UTF-8", damit /etc/env.d/02locales "de_DE.utf8@euro" nimmt).

Ein bisschen musste ich noch Programme bauen, aber das macht mein Rechner ohne dass ich ihn überwachen muss.

Ich muss aktuell noch beim booten "Linux video=ofonly" eingeben, wenn ich die Konsolen sehen will, weil ich noch nicht den richtigen Grafikmodus habe. Ich hoffe, ich kann das bald fixen. Bis dahin stört es nicht. Der X-Server funktioniert und kdm wird sauber angezeigt, sobald der Rechner fertig gebootet ist.

Und jetzt gerade läuft das "emerge -uDN world", um alle bisherigen Programme zu aktualisieren. Als nächstes werden dann xorg-x11 und kde-meta emerged :)

Erstmal wird es noch kde 3.5.x, weil 4.1.2 für ppc noch nicht in testing ist.

Update: Inzwischen läuft alles. Ich musste noch ein paar Programme nachinstallieren (z.B. Firefox und OpenOffice), aber damit ist die Installation abgeschlossen. Alle alten Daten und KDE Einstellungen funktionieren weiterhin, trotz der Neuinstallierung.

Die gesamte Installation hat etwa 2 Tage gedauert - davon alles bis auf die ersten 4 Stunden und etwas Konfiguration (z.B. X via xorgcfg und WLAN) reine compile-Zeit.

Was meiner Frau noch fehlte waren gimp, openoffice, mozilla-firefox und k3b. Ich brauchte noch sudo, screen, cfg-update, eix, euses, gentoolkit und portage-utils. :)

WLAN habe ich über net-wireless/b43-fwcutter , net-wireless/bcm43xx-fwcutter und wpa_supplicant zum Laufen bekommen. Glücklicherweise hatte ich von meiner alten installation noch eine Kopie der Apple WLAN Firmware auf der Platte.

Update 2009-07: xorg braucht für Tastatur und Maus jetzt x11-drivers/xf86-input-evdev.

Update: Infos zur installation von WLAN auf den alten G3 iMacs Flatscreen gibt es im Gentoo Wiki.

Inhalt abgleichen
Willkommen im Weltenwald!
((λ()'Dr.ArneBab))



Beliebte Inhalte

sn.1w6.org news